Showing 1 of 660 conversations about:
Notusingthisagain
1
Jun 26, 2013
bookmark_border
Color me "Not impressed". I got it and plugging it into Windows 7 results in a "device not recognized". I've also tried a Linux machine- same deal so now I've got a $110 paper weight. Yes, I've rebooted, searched for "drivers", tried multiple USB ports, powered it on and off, etc. After wasting a few hours, I scrounged for an old USB cable (it uses the USB-B connector) it turned out that the supplied USB cable was bad and allowed the computers to detect the device, but not communicate with it. So I'm guessing there will be others who get bad cables as well. Secondly, despite the specification on the packing slip and the order, it's the wrong color. Finally, the supply line from the power wart (who the hell puts the wart in the MIDDLE of the cord) is pulled out of the wart so presumably the only thing holding the fire and shock hazard together are a few bits of solder- no idea what sort of transformer this is but hope it's not mega-volts like my tube transformers.
Jun 26, 2013
View Full Discussion