shopping_cart
Showing 1 of 28 conversations about:
Aeskulapio
18
May 21, 2020
bookmark_border
Just received mine this morning. Unremarkable unboxing experience, but like my DM6 and DM7 the shells are well made and attractive. The charging case is a bit big compared to the Samsung Galaxy Buds case or the Apple AirPods Pro, but pocketable. Popped them in my ears with the attached ear tips and they passively isolate well, paired quickly with my iPhone and the sound quality, at first blush, of the podcast I was listening to was good. Then I made the mistake of taking out one earbud to see if they could play independently and I lost that BT connection. I replaced them both in the case, let them charge for 30 minutes tried again, could only get sound out of one or the other IEM. I disconnected them, repaired them, same result. I tried this multiple times without being able to get them to play simultaneously. In fact they show up as separate Bluetooth devices and I can only pair one and get sound out of one at a time. Another member below mentioned turning them off and then on again and tapping the shell 5 times to rest the BT “profile” doesn’t work for me. Searching doesn’t result in any FAQs or troubleshooting advice and I can’t find anything helpful on YouTube. As of now, after about 2 hours of playing with them as true wireless IEMs they seem useless. I don’t have time to try them wired now, but given I have other BGVP IEMs that use case is less interesting. I had thought originally I could carry these for travel and use the wired connection for on plane entertainment units. Post COVID-19 that use case seems less interesting. I’m going to try to get these to work again in a few hours, but if I can’t get them to work in a synchronized manner then I’m going to have to return these.
May 21, 2020
WSKR
0
Jun 19, 2020
bookmark_border
Thanks for the input and reset info. I had the same type of issues at first. After resets, only one earbud at a time would produce any sound. The right earbud even went into a sort of AM radio(hollow lo-fi) sound. They also entered into the bluetooth list as individual earbuds. I did the reset four or five times, then completely deleted the bluetooth profile restarted everything and reconnected with success. Also, they reconnected as one name in the bluetooth list. They work fine now changing from device to device. Thanks again for the info.
Jun 19, 2020
View Full Discussion