Showing 1 of 195 conversations about:
VinnyZ123
9
Dec 31, 2014
bookmark_border
It's been a little over a month, and my Bravo Audio Ocean is dead. I thought maybe it was a problem with the power adapter, but sadly the replacement adapter I purchased doesn't work either. I emailed massdrop in regards to the issue after Bravo Audio says that Massdrop will be responsible for the repair or replacement of this device. This thing was awesome while it lasted, and has a great sound to it. I'm hoping I can get this resolved ASAP.
Dec 31, 2014
christina.nguyen
27
Jan 3, 2015
bookmark_border
Hey, I'm sorry about what's happened with your unit. Did you make sure it was outputting the same voltage? I have the problem of not being able to find the proper adapter for it. Also, my laptop's charger was able to power the amp for a bit until I unplugged it. I was worried it was gonna fry the poor little amp. But hopefully, everything works out for you! I'm still waiting for massdrop support to respond to my email.
Jan 3, 2015
VinnyZ123
9
Jan 3, 2015
bookmark_border
My power supply appears to be dead, but when I try another 24 Volt adapter it will turn on, but then cut off after a minute of turning on. It's definitely more than a power supply issue. I've had emails sent out to both the manufacturer and Massdrop for over a week. Bravo Audio says it's the responsibility of Massdrop to resolve this situation. Considering the recent holidays I will wait patiently for a response from them.
Jan 3, 2015
View Full Discussion