Showing 1 of 18 conversations about:
addedmon
4
May 29, 2015
bookmark_border
According to the review, this requires Android Lollipop. Is that still the case? I know there are a lot of phones still on KitKat.
May 29, 2015
doluseb
124
May 29, 2015
bookmark_border
and some of the functionality requires ios. no thanks
May 29, 2015
On_Song
6
May 29, 2015
bookmark_border
Your Android needs to be compatible with OTG (On The Go). Most new phones and tablets are except Kindle and some phones more than two years old. Check your specs.
May 29, 2015
On_Song
6
May 29, 2015
bookmark_border
The controls are for iOS, there is no requirement for iOS to be used. This works with Windows P.C.'s as well.
May 29, 2015
addedmon
4
Jun 1, 2015
bookmark_border
Thank you for the tip!
Jun 1, 2015
Under_Score96
316
Jul 3, 2015
bookmark_border
So the buttons won't work for Android devices?
Jul 3, 2015
View Full Discussion