Your Friend gave you $10 to spend on your first purchase on Drop! Sign Up to learn more.
shopping_cart
Showing 1 of 1672 conversations about:
Asian_Boi
3
Dec 26, 2020
bookmark_border
Does anyone know if they’ve fixed the ghosting issue from like 2 years ago, or have anti-ghosting firmware? I was looking online while waiting for mine to arrive and seen people with cherry browns (same one I purchased) having this issue, though from like a year ago. If anyone can confirm that they have fixed this issue that would be much appreciated. Thank you. Happy Holidays 🙂
Dec 26, 2020
erickong
6965
Mech Keys Moderator
Dec 30, 2020
bookmark_border
I think that the new firmware helped a lot
Dec 30, 2020
DirtySoc
1
Dec 30, 2020
bookmark_border
I just got this board yesterday and noticed double entry of "u". It seems like this may still be an issue and might not be switch related. I'm still testing and trying different switches. So far the double key entry has only occurred on one letter with the Halo switches that came with the board.
Dec 30, 2020
erickong
6965
Mech Keys Moderator
Dec 30, 2020
bookmark_border
I'd check and see if the contacts within the hotswap socket are okay. See if it's dirty in there for some reason. Or if the stem legs of the switch are okay. I do remember seeing that halos were more prominent with this issue
Dec 30, 2020
DirtySoc
1
Jan 10, 2021
bookmark_border
After another week it seems like the issue is less pronounced. I changed the keycaps and don't notice it as much. I think the switches are just easier to double press if you are not careful how you type. Not sure its a board problem. I rarely have double presses now but they do occur once in awhile.
Jan 10, 2021
Gaetanzo
3
Jan 27, 2021
bookmark_border
I bought my keybboard in late 2019 and over the past month I wouldddd say that the extra key presses issues is getting worse anddd worse. It seems to be located on the bottom left side of the keyboarddd. It started with the d key and has started to slowly progress to the b key and the c key. I swapped the switch for one that wasn't have an issue and I'm still seeing it. I know it's unlikely to be a firmware issue but it does feel like it's something in software as it seems to have fits where it happens more often than other times. I wish I could narrow it down but this very expensive keybaorddd it really starting to suck. I am typing my code left andd right because of this. I am going to try to pull the switches later today and maybe put a double of drops of deoxit into the spot where the leads go for the switches and see if that helps at all. Please note I left all of the extra characters in the post to give you an iddea of what it looks like right now.
Jan 27, 2021
Elbert
2568
Feb 15, 2021
bookmark_border
Comment hidden
help
Feb 15, 2021
Araxi
4
Apr 4, 2021
bookmark_border
hey Elbert.. >.< i am trying DEBOUCE in the config.. but i still getting chatters.. i have to now resort to software.. is there anything else i can do?
Apr 4, 2021
Elbert
2568
Apr 4, 2021
bookmark_border
Comment hidden
help
Apr 4, 2021
Ming
232
Jan 18, 2022
bookmark_border
You can't even identify the problem and you're running around telling people there's a fix. 0% credibility 100% shill, oops I mean Drop Moderator.
Jan 18, 2022
View Full Discussion