Showing 1 of 1243 conversations about:
SnadTheEgg
38
Oct 2, 2020
bookmark_border
Update on the last two posts: I just got my replacements and as everyone else has said, they are f*cking amazing Apparently frequency response was affected by the defect in my last pair, because now I can agree that these headphones are nice and warm. There was barely any bass in my last pair. I'll have to test multi-pair next but so far it's super promising! Edit: I can't seem to catch a break, the volume up "button" is broken. I'm gonna roll with it though, these sound great and I'm impatient.
(Edited)
Oct 2, 2020
AeroKong
2
Oct 3, 2020
bookmark_border
do you know what defect was affecting the frequency response? i think im having similar issues with mine. music doesnt sound very clear when lots of instruments and voclas are happening at once and bass is also very weak compared to some other headphones i have and to the way other people have described the bass in their panda headphones.
Oct 3, 2020
SnadTheEgg
38
Oct 3, 2020
bookmark_border
Honestly, I have no clue. Everything seemed messed up with mine, and especially if you get electrical noise in one ear over USB-C you should email support. If you're an indiegogo backer, you should contact iggsupport@drop.com Otherwise just use the "contact us" button
Oct 3, 2020
AeroKong
2
Oct 3, 2020
bookmark_border
the only electrical noise i get is after audio has stopped for a few seconds and i get an electrical type click on the right side that other people have said is from the electronics powering down into standby mode. i am in contact with support and so far ive just been told to do a factory reset but that didnt work and now im waiting for a response. i just wanted to see what theyve told other people with similar issues.
Oct 3, 2020
View Full Discussion