Showing 1 of 1003 conversations about:
NolanMaxom
11
Nov 28, 2020
bookmark_border
Been using mine for a little over 24hrs now. I was in the August batch. Issues:
  • - Left channel is noticeably quieter and lacking energy. Some bass frequencies missing as well.
  • - Multi-point bluetooth is extremely buggy. I've had the headphone literally crash multiple times already when trying to pair my phone and laptop. Other times one or both of the two paired devices will simply refuse to connect.
  • - When I pause playback on my phone and then try playing on windows, the audio just glitches non-stop and cuts outs. The only way to fix this is to reset the headphones and re-pair.
  • - Out of the box, it didn't exhibit the interference in the left channel. But now 24hrs later, sure enough it's there even while playing audio.
The good:
  • - Clean, detailed sound even at high volume. I noticed details, and sometimes flaws, in files I had listened to many times before.
  • - Capable of some really powerful clean bass once EQ'd. This just makes me even more impatient for the EQ app to be released. But it's good to know they're plenty capable of it.

Currently waiting on DROP support to get back to me. I'll update when that happens. Update (Nov 30): Support got back to me and is going to replace them. Stay tuned. Update 2 (Dec 30): Replacement pair arrived today. They sound great with no issues to report. Even multi-point Bluetooth is working!
(Edited)
Nov 28, 2020
johny_mnemonic
12
Nov 28, 2020
bookmark_border
When mine start to "glitch and cut out" it always helps to just disconnect the second BT device (the mobile phone in my case). No need to restart or even reset the headphones. You just need to have only one device connected. Seems like SW issue to me, that once one device is playing and the second one also plays the sound (like a notification on a phone while listening to music on a PC), it sometimes confuses the FW and until you completely disconnect the device which tried to play as second, it glitches...
Nov 28, 2020
tRuE008
35
Nov 29, 2020
bookmark_border
August batch here too. Got mine earlier this week and I noticed my left channel to be lower as well, but not too big of a volume difference. Still annoying though. What I have trouble with is connectivity. The Panda connects to my PC and Phone with little issues. On the initial pairing, there was skipping and poor quality, but seems to be fine now. However, the Pandas would not connect to my AK Junior and TV, which are two of the devices that I listen to the most, Movies and Music. Support wasn't any help. Support pretty much told me to update all bluetooth drivers, and that's about it.
Nov 29, 2020
KattoJesu
101
Nov 30, 2020
bookmark_border
lets hope drop makes a better version in the future that addresses all the issues of this generation~ Im just concerned that theres a limited supply of the Oppo Isodynamic Planars left. Hopefully the factory producing them is still around.
Nov 30, 2020
ArchiCroc
69
Nov 30, 2020
bookmark_border
"Left channel is noticeably quieter and lacking energy. Some bass frequencies missing as well." Do you happen to being using them wired, either Analog or USB-C? I've noticed a little asymmetry in mine when a port on one side is connected and the other isn't. It's like some sound pressure is escaping out the open ports and when the air leak is sealed, the tonality shifts a little on that side.
Nov 30, 2020
NolanMaxom
11
Dec 1, 2020
bookmark_border
I tried it with all 3 configurations. Surprisingly, on mine I couldn't notice a difference with the ports plugged or open. In all cases the left channel was quieter and lacking bass. Maybe it's cause my left channel is already defective so blocking the ports isn't noticeable? At first I thought it might just be my ears, but I got other people to listen and confirm it as well. Also I tested it in forced mono, and there the difference was even more apparent, cause the exact same signal is going to both channels.
(Edited)
Dec 1, 2020
NolanMaxom
11
Dec 1, 2020
bookmark_border
Ya that's a bummer. The only thing I can suggest is getting a Fiio BTA30. Others have confirmed it works well with the pandas, and you'll also have the benefit of LDAC.
Dec 1, 2020
Han45
3
Dec 2, 2020
bookmark_border
Hi there, I'm gonna copy and paste your entire experience to support. Same batch and exactly what I'm going through. I'm still not sure if the channel balance is psychological for me but everything else w/o a doubt. Very frustrating. I'm getting the audio glitches, hissing & popping on my Samsung S10+ too. The primary use case for this is the BT audio, and if that can't work then i don't even know why. Dusted off my PM3s. Felt like a breath of fresh air.
Dec 2, 2020
View Full Discussion