Showing 1 of 24 conversations about:
keegs_is_the_squeeze
13
Jun 26, 2015
bookmark_border
So I'm a little disappointed so far. I had been eagerly waiting for my Slate to arrive, and when it finally did I've had nothing but issues. The hardware itself is in perfect shape; it connects to my computer, is recognized, pads light up. However, the included software, Serato DJ intro will not recognize the controller, stating "Hardware Disconnected". I've uninstalled and reinstalled the drivers and DJ intro multiple times to no avail. I've tried different USB ports to no success. Does anyone have any tips?
Jun 26, 2015
SeanReid
345
Jun 26, 2015
bookmark_border
So sorry to hear you are having connectivity issues, that is a bummer! Please feel free to contact either of these two fellows at Gemini Sound for help:
Angel.resto@geninisound.com
Or
Eric@geminisound.com
Let us know if the issue was resolved.
Jun 26, 2015
keegs_is_the_squeeze
13
Jun 29, 2015
bookmark_border
I was able to get my Slate to work properly with my Windows 7 computer. I originally tried it on a Windows 8.1 machine, but it looks like Windows 7 downloaded some additional drivers in addition to the ASIO driver provided on the website, which I think is the key to the "hardware disconnected" issue. I am looking to see if I can get the additional drivers on to my Windows 8.1 machine.
Jun 29, 2015
SeanReid
345
Jun 29, 2015
bookmark_border
Great!
Glad to hear you worked it out and thanks for sharing the info with the community. You never know who else might need a little help in troubleshooting.
Jun 29, 2015
View Full Discussion