Showing 1 of 520 conversations about:
Dnguyen926
8
Jul 3, 2018
bookmark_border
Hi, guys
search

search

search

search
so I plugged my CTH in yesterday and the tube made a loud popped. I turned it off and tried to remove the tube but it cracked. Do you guys have any ideal what happened and is the amp okay?
Jul 3, 2018
tholt
57
Jul 3, 2018
bookmark_border
Bummer. Could be a bad tube, or something wrong with the amp. I think getting a new tube that you know is good and trying it will help figure things out
Jul 3, 2018
CEE_TEE
3476
Jul 12, 2018
bookmark_border
We're seeing some tube issues and wonder if installation is causing some leaks at the pins. There does need to be care taken and feel used in order to install the pins, the amp should be okay with a new tube. We are working on having replacement tubes available but this requires a new SKU and packaging, we are looking into the cost for this.
Jul 12, 2018
timothom
82
Sep 19, 2018
bookmark_border
Any progress on getting those replacement tubes yet? I'd like order one to have a spare.
Sep 19, 2018
CEE_TEE
3476
Sep 19, 2018
bookmark_border
We're having a meeting with our manufacturer Friday, I'll bring it up again...thanks!
Sep 19, 2018
timothom
82
Sep 20, 2018
bookmark_border
Thank you @CEE_TEE . My CTH is my daily driver, and I love the way that it sounds. The tube included with it has given me no issues so far. Massdrop is killin it.
Sep 20, 2018
CEE_TEE
3476
Sep 20, 2018
bookmark_border
Much love, thank you for the kind words...keeping me going!
Sep 20, 2018
RK2018
47
Sep 20, 2018
bookmark_border
I want to add my thanks, too. I listen to (and really enjoy) my CTH for hours every day at work. I’m kicking myself that I missed the R2R DAC drop.
Sep 20, 2018
timothom
82
Sep 20, 2018
bookmark_border
I'd love to hear one of those sometime. I have yet to hear a DAC change that actually means a meaningful difference in my sound.
Sep 20, 2018
View Full Discussion