shopping_cart
Showing 1 of 990 conversations about:
i3nu
23
Nov 28, 2017
bookmark_border
Hi,
Today I received my K-Type keyboard.. It's an awesome keyboard and I like it very much.. I tried it on my office PC and it worked flawlessly, then I brought it along with the intend to use it with my laptop, but suddenly it didn't work, my laptop didn't recognize anything after i plugged the USB, at first i thought it was my laptop, I went home and tried it again at my home PC, and it still have the same problem, my PC couldn't recognize it either..
The issue, whenever I plug the keyboard to any USB slot, the RGB light goes up.. very beautiful, but after a few second it went off.. Windows didn't recognize any device plugged in..
Can you tell me what the problem is? I checked the internet, and I found that there is a flash switch under the keyboard but I am a newbie techie, and I do not dare to do anything risky at this point, so I'm writing to know what to do, does anyone have same problem?
Thank you
Nov 28, 2017
TragestyX
285
Nov 28, 2017
bookmark_border
It needs to be plugged into a USB 3.0 or it won't work it.
Nov 28, 2017
darbysuperhack
4
Nov 28, 2017
bookmark_border
Not true. I have mine in USB 2 and it works fine. I haven't been able to get programming to work yet though.
Nov 28, 2017
c_r_z
812
Nov 28, 2017
bookmark_border
Try lowering the LED intensity a bit, mine has issues on full brightness with white backlight even on USB 3.1 gen 1 (aka USB 3.0).
Nov 28, 2017
TragestyX
285
Nov 29, 2017
bookmark_border
I haven't plugged it into any USB 2.0 that actually works.
Nov 29, 2017
TheMadClacker
44
Nov 29, 2017
bookmark_border
You have to flash the firmware. The firmware that it ships with is no good. Mine stopped working completely until I did this. Check the manual. I left you a link https://github.com/kiibohd/controller/blob/master/Documentation/Keyboards/K-Type.md
Nov 29, 2017
i3nu
23
Nov 29, 2017
bookmark_border
done nothing happened, tried both USB 3.0 and 2.0, and also tried USB 3.0 hub with external power.. tried to connect it both to USB 3.0 and 2.0, still nothing happened..
Nov 29, 2017
i3nu
23
Nov 29, 2017
bookmark_border
Can you tell me how to lower the LED intensity?
Nov 29, 2017
i3nu
23
Nov 29, 2017
bookmark_border
the problem is that windows didnt recognize any hardware connected.. ( API Interface (Interface 5) nothing about this at all)
Nov 29, 2017
c_r_z
812
Nov 29, 2017
bookmark_border
Fn and +/- control LED intensities by default, at least in the firmware that is flashed by the offline configurator.
Nov 29, 2017
TragestyX
285
Nov 29, 2017
bookmark_border
You have to install the drivers then. They must not be on your computer. Those instructions are on the github.
Nov 29, 2017
heat_death51
138
Nov 29, 2017
bookmark_border
Not what you would expect to have to do with a $200 keyboard huh? Unfortunate.
Nov 29, 2017
TheMadClacker
44
Nov 29, 2017
bookmark_border
Yeah I was pissed off didn’t ship with stable firmware. It is an enthusiast board, but still...
Nov 29, 2017
TheMadClacker
44
Nov 30, 2017
bookmark_border
That happened to me too at first. I tried different combinations of plugging it in and unplugging it and restarting the computer until it worked.
Nov 30, 2017
i3nu
23
Nov 30, 2017
bookmark_border
oh yes and i tried to use it at startup bios menu but it didn't work >.<
Nov 30, 2017
i3nu
23
Dec 2, 2017
bookmark_border
How do I return this keyboard?
Dec 2, 2017
View Full Discussion