Showing 1 of 319 conversations about:
Jeff-D
203
Mar 28, 2018
bookmark_border
Does anyone drive these with the v20? How is your experience with it?
Mar 28, 2018
Sacrinis
6
Mar 29, 2018
bookmark_border
I use the V30 and they sound absolutely incredible. Just wish the paint didnt chip off on them!
Mar 29, 2018
Jeff-D
203
Mar 29, 2018
bookmark_border
Thanks. I'm a little nervous because of all the stories about defects people talk about on here but the discount was so good that I'm hoping it will be worth the risk.
Mar 29, 2018
mrduckderpalot
5
Mar 30, 2018
bookmark_border
quite unfortunate since the paint is high quality, its just the type of metal alloy used does not stick with the paint.
Mar 30, 2018
Jeff-D
203
Mar 30, 2018
bookmark_border
Yeah I can see how it wouldn't that makes sense. I am more worried about the tube thing, a filter maybe i'm not sure what its called, breaking off.
Mar 30, 2018
mrduckderpalot
5
Mar 31, 2018
bookmark_border
Just try not pulling too hard on that. Never had any problems with the filters
Mar 31, 2018
Jeff-D
203
Mar 31, 2018
bookmark_border
Thanks! I got it yesterday and i must have tried almost all the tips. It feels solid.
Mar 31, 2018
scottm_dj
12
Apr 23, 2018
bookmark_border
Does the 50ohm rating trigger the high-impedance (more power) setting on the v30?
Apr 23, 2018
mrduckderpalot
5
Apr 23, 2018
bookmark_border
Tried the PX paired with v30. Sounds really good with the hifi on
Apr 23, 2018
gemmoglock
59
May 6, 2018
bookmark_border
Works with V20, triggers high impedance mode mostly, if it doesn't it usually works by plugging out and in again. Sounds great.
May 6, 2018
View Full Discussion