Showing 1 of 407 conversations about:
anoymnus
6
Apr 23, 2018
bookmark_border
I have an issue. Idk if its QC, or USPS hates me,(-.-) but whenever I would use my EDC3s, the wire would just unplug themselves for no reason. Can anyone help? (I was part of the first group to order, back in Februry.)
Apr 23, 2018
CEE_TEE
3399
Apr 24, 2018
bookmark_border
Hey anoymus, Sorry to hear you are having an issue...do both sides (Left/Right) exhibit the same behavior? Do both cables do the same thing? Wondering if one cable is an issue or an earpiece...
Apr 24, 2018
Jyri
814
Nuforce
Apr 24, 2018
bookmark_border
I´ll jump in as well. :-)
Can you check that you have plugged the cables properly? The connector should go all the way in. It can be quite stiff at first. Also, does this happen with both cables?
- Jyri/NuForce
Apr 24, 2018
anoymnus
6
Apr 30, 2018
bookmark_border
I am so sorry for the late response, but I'll take the time to recorrect myself. Over time, just from day to day use, I believe it was my left earpiece that the cable would unplug occasionly, signaled to me by the loss of my music in one ear. I don't know why this is the case. I did indeed plug them in as best as I can, and they were quite stiff, but as I said earlier, as the day would go on, the left cable would just detach itself. I have already notified support of this issue, and they offered a replacement. I am onboard if you want me to send my earpieces out to see why. I did change the eartips with aftermarket eartips from comply as well. Comply Comfort 100 to be precise.
Apr 30, 2018
anoymnus
6
Apr 30, 2018
bookmark_border
Alright, support has contacted me, and I have chosen the option to return the device in exchange for a replacement, I will see if the issue persists or not.
Apr 30, 2018
Jyri
814
Nuforce
May 3, 2018
bookmark_border
Shouldn’t persist, but please keep me updated so that I am aware as well. I’ll regroup with CEE_TEE and see if we could get hands on the earlier pair. Thank you for your support and patience!
May 3, 2018
View Full Discussion