Showing 1 of 37 conversations about:
GunnyHighway07
3
Dec 21, 2014
bookmark_border
I've been using the A151 nearly daily since April 2011, and other than replacing the 3.5mm jack, they've been absolutely amazing in sound and build quality. I was paranoid that eventually they're gonna bite the dust and bought the A151P off of this drop as a backup set. I just tried them out and they sound horrendous compared to the 1st gen. Hollow, no character, and very distant sounding. I'm gonna plug them into my PC and let them run a few days. Hopefully they just need to be worked in..
This combined with the 3 pairs of A161P I went through (1 new, 2 RMA, all broke at the cable relief on the left ear) before they finally pulled the product has a long term customer worried for future products.
Dec 21, 2014
Strikeplasma
1
Dec 27, 2014
bookmark_border
how did yours go after being burned in a few days?
Dec 27, 2014
GunnyHighway07
3
Dec 28, 2014
bookmark_border
No noticeable change for the better. Even running them off of a Bravo V2 made little difference. I think it's safe to say that Meelec really dropped the ball on these. Another thing I noticed was that the button for the mic rattles around like crazy and it transfers that rattle straight through the wires to your ear. To be fair I don't know if the first gen A151p models had the same issue since I have the A151.
All in all, I would rather pay the $75 I paid originally for the amazing sound than save $35 and get crap.
Dec 28, 2014
Strikeplasma
1
Dec 29, 2014
bookmark_border
Is it possible we got a lemon batch? Box advertises a slightly warm tone, but mine is no where near a warm tone. I've burned ut in for 100+ hours already and no signs of it going better. Bass is almost not present on mine as well.
Dec 29, 2014
View Full Discussion