Showing 1 of 124 conversations about:
Shenanigans
177
Oct 24, 2016
bookmark_border
I got the HEM6's from a bluebox drop a few months ago. I love the sonic performance, and fit / comfort, but there are some issues with the cords. the "audiophile" twisted cable tangles very easily and if it gets twisted in the opposite direction of the helix, the individual strands in the twisted pair will come apart and get individually tangled... making a real mess. As for the headset cord (the one with the built-in mic) I had callers complain of weird echoing and very poor sound quality on the other end of the line. Also, the rubber jacketing on that cable started to stretch and separate after just a few months and just recently has torn apart , exposing the individual wires and strength members inside. The worst of the damage seemed to be caused by the little slide ( that protects the "Y" junction and adjusts slack going to each ear), although the jacketing over the area that bends over the ears has also started to stretch apart: its just poor quality materials applied too thinly.
There is also an issue with where / how the cables connect to the actual IEM's: it's just a press/friction fit that slowly works lose over time. The friction fit has also started to degrade so that the time it takes from them to work lose becomes less and less.
Lastly, (and most importantly IMO) is that support is literally nonexistent: the contact link for US support on their website does not work / is blank and I've tried contacting them a few times via their FB page and never received a response.
No bueno.
Oct 24, 2016
Jyri
816
Nuforce
Oct 25, 2016
bookmark_border
I checked our Facebook and indeed there was one message in June which our team has missed. All the other messages have been answered - include the one you sent today. I understand that customer service should be accessible immediately regardless of place and time and we apologize that this was not the case. However I can´t really admit or agree that our support is nonexistent. Let´s continue over FB or emails but to answer shortly on the cables. The call echo should not be caused by the cable, and there isn´t any quality fault with the rubber jacketing or connectors. The connectors itself are tested thousands of times to make sure the fit is stable and won´t get loose. Yet, of course the experience you´ve had is unacceptable and we are more than happy to arrange new cables to you. Our apologies for the inconvenience. -Jyri/NuForce
Oct 25, 2016
Stephen879
63
Nov 10, 2016
bookmark_border
I just got mine and I actually came here to see if anyone had figured out the cable-to-IEM connectors. I finally figured it out. I guess. And that was the first time I tried to connect the "high-end" cable to the IEMs. So it's disheartening to hear that they will get worse. I also had the exact same experience with their website and FB page. Anyway, thanks for taking the trouble to post.
Nov 10, 2016
Shenanigans
177
Jul 14, 2017
bookmark_border
Some time after this post I did have a better experience with Optoma (NuForce's parent company) support. I think after reading this tread, someone from the company did finally get back to me via facebook to let me know that their support page on their website was updated and contained actual warranty and contact info. https://www.optomausa.com/warranty.aspx The number for North American support connected me to a real person who sounded like a native English speaker who was very friendly and helpful. He actually pre-populated the RMA form for me and emailed to me so all I had to do was print it and include it box when I sent the HEM6's back. Supposedly they're just going to replace everything, and the issues that I had with the cords where hopefully worked out in later production runs. I'll update the thread after I get the replacements.
Jul 14, 2017
View Full Discussion