Showing 1 of 227 conversations about:
Visceralwaves
15
Nov 3, 2016
bookmark_border
Has anyone had an issue where one of the earpieces has intermittent issues with a scratchy static like sound that is prompted by and/or made worse with slight movement of the cable or lightly touching the earpiece. It is not so loud it hurts the ears or over powers the music, but is definitely noticeable when it occurs. Is it possible it is a cable / connection issue? It doesn't really seem like a connection issue, it started before I ever disconnected the cable from the earpiece and doesn't appear to get worse from touching the connection point (touching the cable can prompt it, but it is equally bad just by touching the earpiece ever so lightly). These have not had more than 60 to 80 hours of light use and have been babied (both physically and from a volume sense), so I am pretty surprised by this. Especially given how sudden it started and how intermittent it is.
If anyone has experienced this before and may know the cause or what was required to fix it, I would greatly appreciate some input.
I actually really enjoy the sound signature of these IEMs, and find them very comfortable as well, so I would really hate having to return these. Not to mention the amount of time it took to receive the unit through the drop initially, and now the time that will probably be needed to ship, have them fixed, and shipped back.
Nov 3, 2016
Jyri
816
Nuforce
Nov 17, 2016
bookmark_border
This definitely is not normal, and it should not occur. The question is whether it is the cable or the earpiece. Regardless, are you located in the USA? If yes then we could help you directly and make sure that you get replacement unit as soon as possible. - Jyri/NuForce
Nov 17, 2016
Visceralwaves
15
Nov 17, 2016
bookmark_border
Hi Jeri, thank you for your response.
Yes, I'm in USA (currently Seattle, WA). I contacted MD, who referred me to NuForce support, who referred me to another support link / form, which I have not yet completed. Partly because I will be moving soon and not quite sure how involved or lengthy this process will be, and subsequently which address to give (moving out of state to CO). Thoughts?
In regards to cable vs earpiece, ultimately I don't know either, but strongly suspect the latter.
Now that this issue has happened to me, I seem to notice quite a few other similar complaints in both this and the HEM drop discussions. Is this a common issue with either these particular IEMs, or perhaps BA driver setups in general? I completely understand that even the best company will have some degree of manufacturing defects, which is fine, but can you please share some insight?
Nov 17, 2016
View Full Discussion