Showing 1 of 184 conversations about:
MrBanana
3
Feb 3, 2016
bookmark_border
Just received mine Today. Pads are glued. The metal face of the cable collector came right off when arrived. Headphone structure seems a little bit different from the pair I just returned to amazon. This one has a wire exposed near the right side pivot with some ugly glue residue which I didn't see on my last pair. As for the sound, last one was splendid. Don't even want to try this pair. Would not trust any Gibson or Phillips product anymore. They are treating their top line product as trash. Last pair bought from Amazon for 199 returned because the chrome decoration rings around the ear pads popped out. Glue under those ring were not strong enough. It seems all problems around this headphone are caused by glue.
search

search

search

search
Feb 3, 2016
steve3236
16
Feb 3, 2016
bookmark_border
Wow that exposed wire is sketchyyyyy. Philips really had something good, why did they(or let gibson) shit the bed on quality control.
Feb 3, 2016
LordMcNasty
0
Feb 4, 2016
bookmark_border
Did you noticed the exposed wire on yours too?
Feb 4, 2016
NuclearPowerofAttorney
1
Feb 4, 2016
bookmark_border
The phrase, "The straw that broke the camel's back," Should be changed to, "The glue that destroyed one of the best headphones."
Feb 4, 2016
badgerbadgerbadger
16
Feb 4, 2016
bookmark_border
Exposed wires? Nice. You got the steampunk version.
Feb 4, 2016
steve3236
16
Feb 4, 2016
bookmark_border
No exposed wires on mine.
headphones sound great after some testing. Good bass, sharp highs. Mids are a little recessed. Haven't really experienced any sound stage yet. Ill be back in a few days with what I hear.
Feb 4, 2016
ShampooCA
49
Feb 4, 2016
bookmark_border
Damn, this is discouraging.
Feb 4, 2016
View Full Discussion