Showing 1 of 13 conversations about:
hardcase
1
Aug 19, 2016
bookmark_border
I think you need the compatibility kit in order to play on the old maps with the "deluxe" components. The BGG store sells it: http://boardgamegeekstore.com/products/deluxe-power-grid-compatibility-kit
Aug 19, 2016
javajoe96
3
Aug 19, 2016
bookmark_border
Hardcase, I'm pretty sure that compatibility kit is only so people who own both power grid and power grid deluxe to play base power grid with the upgraded wooden pieces from deluxe and this kit.
Aug 19, 2016
View Full Discussion