Showing 1 of 315 conversations about:
WampaStompa
5
May 8, 2017
bookmark_border
Anyone else having issues with left side (ctrl, alt, windows) keys' LEDs? It seems weird for them all to be down. I soldered them in just like anything else. Solder looks solid. Not sure.
May 8, 2017
furf79
4
May 8, 2017
bookmark_border
Did you get the polarity right? If you are going for a basic layout, the switch and LED position has the LEDs in the reverse direction (left three switches) to the rest of the PCB. If you didn't rotate them to be the opposite of the others, that would explain your issue.
May 8, 2017
WampaStompa
5
May 8, 2017
bookmark_border
Ok, that's it, the right ones are the same way though... Is it just the left ones that are like that?
May 8, 2017
furf79
4
May 8, 2017
bookmark_border
Yeah, because when you shift the switch for the keycap to fit, it uses the other set of holes, which swaps the polarity.
May 8, 2017
WampaStompa
5
May 8, 2017
bookmark_border
Ok, because it is matching the markings for polarity, and the polarity is marked to be swapped for the position i didn't use. I will desolder and just put a new LED in there and mess around with it before resoldering.
May 8, 2017
WampaStompa
5
May 9, 2017
bookmark_border
Thanks for the help. You fixed my problem!
May 9, 2017
furf79
4
May 9, 2017
bookmark_border
No problem. I'm glad I could help and that you got it working. I should have a resistor on the way and hopefully that fixes my one LED that is out.
May 9, 2017
View Full Discussion