Showing 1 of 246 conversations about:
MitchRusso
28
Jun 12, 2017
bookmark_border
I received mine Friday and I tried to power it and it doesn't work. The display shows Opti2 but the source cannot be changed. The remote does not control the AD-18. I then realized that the product has no U.S. tech support. I sent an email but who know what happens next.... Beware buying a product with no US support.
Jun 12, 2017
Trunk
1
Jun 12, 2017
bookmark_border
Have you tried to press the A button on the remote? I've seen that come up a lot. Otherwise, make sure that the batteries are fresh and inserted properly.
Jun 12, 2017
TheWayWeTalk
12
Jun 13, 2017
bookmark_border
press the volume nob and then spin to cycle through the different inputs
Jun 13, 2017
MitchRusso
28
Jun 13, 2017
bookmark_border
Thanks! That move let me get the BT connection set up and hear the amp for the first time. I am waiting for a new remote to come from the factory. So far so good.
Jun 13, 2017
MitchRusso
28
Jun 17, 2017
bookmark_border
Unfortunately that had no effect. 5 days now waiting for someone to get back to me on a replacement remote. The factory responded and told me that someone at MassDrop would send out the new remote but no response there either.
Jun 17, 2017
Trunk
1
Jun 17, 2017
bookmark_border
Bummer. I hope for your sake it's the remote and not the IR receiver on the amp. Please keep us updated. I joined the drop. Fingers crossed, but one or more of us might wind up being in the same boat as you.
Jun 17, 2017
View Full Discussion