Showing 1 of 244 conversations about:
MitchRusso
28
Jul 14, 2017
bookmark_border
My AD18 arrived and the remote didn't work. After several emails, and almost a month later, I received a replacement remote from Japan. It tuns out the new remote doesn't work either. Now the company is non-responsive when I requested a replacement.
Beware, you are buying a product with no US support. If you get a defective unit, then it may be months before you get service AND you may not get service at all.
Sorry guys, that's been my experience and I thought I would provide this information before you buy from this company.
Mitch
Jul 14, 2017
Spanky578
6
Jul 14, 2017
bookmark_border
Did you try pushing the A button? I had the same issue until I depressed the A button, and the remote then functioned normally.
Jul 14, 2017
ljbell97
29
Jul 17, 2017
bookmark_border
looks like someone didn't read the manual lol
Jul 17, 2017
MitchRusso
28
Jul 18, 2017
bookmark_border
Yes, you are correct. I actually read the manual but didn't see that! So thank you for pointing it out. It seem to have modal controls which I've never seen before in an audio remote. But it is working now.
Mitch
Jul 18, 2017
Trunk
1
Jul 18, 2017
bookmark_border
I recommended the same thing to him five weeks ago, and he said it didn't work. Glad it's resolved now! Sorry if I wasn't clear, Mitch.
Jul 18, 2017
MitchRusso
28
Jul 19, 2017
bookmark_border
Trunk, It didn't work 5 weeks ago on the old remote. The company sent me a new remote and now it does work.
Jul 19, 2017
Trunk
1
Jul 21, 2017
bookmark_border
I believe you. I just thought it was funny that my suggestion was actually a solution, albeit with a second, functioning remote. I'm glad it worked out for you. Hope you're enjoying them amp. I am.
Jul 21, 2017
View Full Discussion