Showing 1 of 41 conversations about:
bjw
290
Apr 12, 2016
bookmark_border
So I just received mine today and it doesn't work, They sent me the AC190V-240V input?? There was never an option to send the 120V, I just assumed that there wasn't one that they would send the US version. Nice $530 wasted
**EDIT**
Not sure what the issue is actually but here is a video of it
http://puu.sh/ofUAV/48ccc10312.m4v
Apr 12, 2016
clarprof83
2
Apr 13, 2016
bookmark_border
Mine does the same...
Apr 13, 2016
BetaWolf
13
Apr 13, 2016
bookmark_border
Mine is supposed to come in tomorrow. Now I am worried.
Apr 13, 2016
sirobkcin
4
Apr 13, 2016
bookmark_border
yes, mine is doing the same as well - i have to check if it's the 190-240 version as well.
Apr 13, 2016
bjw
290
Apr 13, 2016
bookmark_border
SO I got my SMSL LPS P1 from eBay and attached it to the SMSL M8 that I got from here and this is on the bottom. I hooked up the Panda Dac and Amp to it and it works fine. but not with the Set that came along with this drop.
search

So there is something wrong with the whole Panda Set
Apr 13, 2016
sirobkcin
4
Apr 13, 2016
bookmark_border
so just got back to my office and yes my set is wired for 190/240 as well. i sent a 'did not arrive as expected' note to massdrop in response.
Apr 13, 2016
brainwave
648
Apr 15, 2016
bookmark_border
How much did you pay for LPS P1? I'm contemplating to get one and some eBay sellers have a "make an offer" option.
Apr 15, 2016
bjw
290
Apr 15, 2016
bookmark_border
Apr 15, 2016
brainwave
648
Apr 15, 2016
bookmark_border
ugh, thanks! good to know... that's the same price as Amazon... will get it from Amazon then. I read a professional review that said M8 jumps to the next level in sound quality with LPS P1.
Apr 15, 2016
View Full Discussion