Showing 1 of 229 conversations about:
TheDetweiler
8
Apr 7, 2019
bookmark_border
did anyone else have an issue were their vortex just died? is there some sort of warranty because I'e had it for just over a year and today it just seemed to stop working.
Apr 7, 2019
TheDetweiler
8
Apr 7, 2019
bookmark_border
upon further investigation is seems to be the microB port on the front. If i jiggle the plug around itll come on sometimes but its not consistent and i havent been able to get it to reconnect. Is there any warranty information?
Apr 7, 2019
superBroman14
4
Apr 23, 2019
bookmark_border
Hey I just had this happen to my board aswell. Left it unpluged at work over the weekend and ame back, plugged it in and it is not working at all. Unfortunatelly wiggling the connection does not work for me.... I sent massdrop an email to see if there is a warranty. Have you found anything out in the time since you posted this?
Apr 23, 2019
TheDetweiler
8
Apr 23, 2019
bookmark_border
Well even wiggling the plug mine eventually stopped working and now mines a paper weight as well. And no i haven't heard anything else apart from you. I sent Vortex an email with no response. Let me know what massdrop says in their email so maybe we can luck out.
Apr 23, 2019
superBroman14
4
Apr 24, 2019
bookmark_border
They told me that since its been 5 months (over their 30 day grace period) they couldn't help me. They told me to contact Vortex. I shot them an email but have not heard anything back yet. What a bummer....
Apr 24, 2019
View Full Discussion