Showing 1 of 65 conversations about:
PieterKdeVilliers
3
Feb 2, 2016
bookmark_border
search
Feb 2, 2016
gjhartog
0
Feb 2, 2016
bookmark_border
And exactly what happened to my xDuoo TA-03 as well!!! Gone in a split second. Alhtough on the site of Massdrop they mentioned 220-110 Volts (so I thought thats OK) they obviously send a 110 Volts amp to Europe in fact to the Netherlands!!! Inside the receptacle on the housing you cab see "250V" by the way!!
Feb 2, 2016
PieterKdeVilliers
3
Feb 2, 2016
bookmark_border
And now all there is is a deathly silence. No response to this problem whatsoever. Does anybody work here? So $200 for the unit. $20 for shipping and another £36 for import tax, and I have nothing!
Feb 2, 2016
nicpope
447
Feb 2, 2016
bookmark_border
Hey all,
We've just been made aware of this problem by customer service and are looking into what is causing the issue and solutions. Please bare with us while we sort it out. Anyone affected please reach out to customer support so they can log a ticket for you and get you taken care of.
Feb 2, 2016
gjhartog
0
Feb 3, 2016
bookmark_border
Hi So if I understand it well, I have to make contact with Customer Service to make them aware of my problem?
Feb 3, 2016
jupiterianvibe
15
Feb 4, 2016
bookmark_border
I contacted the customer support and they replied in a day offering what they can do. You need to do the same.
Feb 4, 2016
gjhartog
0
Feb 13, 2016
bookmark_border
Hi, did they reply ?
Feb 13, 2016
jupiterianvibe
15
Feb 14, 2016
bookmark_border
Yes, they asked me to return the unit for a refund. I shipped it back and waiting for it to arrive massdrop warehouse then they will pay me back. They also reimburse back-shipping costs.
Feb 14, 2016
gjhartog
0
Feb 14, 2016
bookmark_border
Ok great!! I didnt hear anything yet from them. Tnx for the answer!
Feb 14, 2016
Justin_1
29
Dec 30, 2016
bookmark_border
out side on the box it came in did it say 110v only?
Dec 30, 2016
View Full Discussion