shopping_cart
Showing 1 of 328 conversations about:
mechkeys
3
Apr 30, 2017
bookmark_border
My kit came today and I just finished assembling it. Looks great. The backlight isn't enabled though - not sure if this is something that needs to be enabled in software somehow or if it's defective.
Apr 30, 2017
MelGeek
3537
0.01
May 1, 2017
bookmark_border
both Fn + Up and Fn + Down can change backlight. Please try it.
May 1, 2017
mechkeys
3
May 1, 2017
bookmark_border
Thanks, I tried it but no luck. Note I'm using the keyboard with a Mac where Fn + Up and Fn + Down are both bound by default to some window management actions. Any other ideas?
May 1, 2017
MelGeek
3537
0.01
May 1, 2017
bookmark_border
you can use the progamming tool to reset function key, but only support Windows now, so you may need find a computer running Windows. fortunately, all your change will be automatically saved.
BTW, we've updated the firmware, please update firmware first.
https://drive.google.com/open?id=0B6OlsxK8tzdnMDk1TkpIa21aWVk https://drive.google.com/open?id=0B6OlsxK8tzdnZ21ScGtGckNBbFU https://drive.google.com/open?id=0B6OlsxK8tzdncG92SDdpZHJ2cms
search
you can set any key here.
search
May 1, 2017
mechkeys
3
May 2, 2017
bookmark_border
Firmware update worked fine and I confirmed the Compile Date was updated to May 1st. I can reprogram the keyboard successfully with KBTools.exe but still no backlight. I tried moving the LED mode and the backlight increase/decrease to other keys but nothing on the board.
May 2, 2017
MelGeek
3537
0.01
May 2, 2017
bookmark_border
I think you may confuse the positive and negative of LED.
May 2, 2017
MelGeek
3537
0.01
May 2, 2017
bookmark_border
search
from this picture you'll see the electrodes the negative one is the larger of the two. so please make sure that the negative is on the left.
May 2, 2017
mechkeys
3
May 2, 2017
bookmark_border
Hm I soldered the LEDs with the longer lead inserted on the left, aligned with the "A" label on the switch housing. Based on your picture that appears correct. Any other tips for debugging?
May 2, 2017
MelGeek
3537
0.01
May 2, 2017
bookmark_border
can you take a picture and upload it?
May 2, 2017
MelGeek
3537
0.01
May 2, 2017
bookmark_border
and the longer pin must be on the right.
May 2, 2017
mechkeys
3
May 2, 2017
bookmark_border
Thanks, I definitely reversed it then. I assumed all boards wired the anode to the left of the MX like here: https://learn.sparkfun.com/tutorials/cherry-mx-switch-breakout-hookup-guide. Debating whether it's worth fixing or not :)
May 2, 2017
tetracycloide
15
May 8, 2017
bookmark_border
Is there some repo somewhere we can check for future firmware updates? Anywhere we can find instructions for KBTools?
Edit: http://www.zpzotech.com/ appears to be the place for this. Or at least as much of this as there is.
May 8, 2017
Keybler_elf
37
Aug 22, 2017
bookmark_border
I updated firmware, and now whenever I hit any key it outputs a huge string of characters. any resolution for this?
Aug 22, 2017
MelGeek
3537
0.01
Aug 23, 2017
bookmark_border
Could you tell where are you buy Z70? I think maybe you buy it from someone else. Because we sent some samples to people for review before first drop long time ago, but after that we redesigned PCB. if so please send an email to me, then I'll send old firmware to you.
Aug 23, 2017
Keybler_elf
37
Aug 23, 2017
bookmark_border
yes I bought it secondhand. I emailed you through your website also, but if you have another email I should respond to let me know.
Aug 23, 2017
Keybler_elf
37
Aug 23, 2017
bookmark_border
Thanks for providing firmware! Perfect resolution, everything is working great!
Aug 23, 2017
View Full Discussion