shopping_cart

Help the configurator compile and download does not work for me. Massdrop ALT keyboard configurator.

more_vert
Hi, I've finished mapping and adding led colors to the configurator and saved my progress. When I tried to compile and download it's stuck in a never ending loading circle. It literally does not download even if I leave it for an hour or refresh it after an hour and try again. Tried using chrome or edge nothing works. Please help.
4
17
remove_red_eye
1.4K
kdr1
5

search
close
NickAppleese
2
Mar 11, 2021
Configurator is now not working for me, either. Setup multiple layers for it to "compile" indefinitely. Sucks.
DrivenKeys
33
Mar 3, 2021
The online configurator is pretty nice, but can run into bugs. Once you see the red box saying TEMP ERROR BOX Internal Error, the firmware will no longer compile. I spent hours putting together the base for the perfect 15 layers, just to have this error permanently destroy that work. Fortunately, I was able to rebuild. If anybody else has these problems, try manually selecting new custom color values. I found that my firmwares were breaking after I'd type in the color values. That, and I reduced layers from 15 to 11. Hope this helps.
(Edited)
Recgraphics
1
Feb 18, 2020
hopefully this is fixed ASAP need this configuration soon!
sic2
3
Feb 17, 2020
I am having this issue right now. Tried on chrome, firefox and safari and always stuck. My configuration is: https://drop.com/mechanical-keyboards/configurator/config/8987
Formseven
0
Feb 18, 2020
Its the same for me. Got my CTRL on Friday and the config worked fine for about 3 days and then stopped. Endless loop. Only changes I ever made to it were the LEDs. Nothing advanced. I was skeptical when I first read it used an online firmware. Wished I had done more research.
sic2
3
Feb 19, 2020
it is now working for me!
zartc
5
Jul 22, 2019
Would be nice to have an error message returned instead of the never ending loading circle! I've been stuck with this syndrome all week-end thinking the compiler was "on maintenance" for the week-end whereas apparently that was just my layout that did not compile.
You most likely have an invalid keymap. Any key with () needs to have its options filled in. For example, if you see MO(), that means you did not select a layer to momentarily switch to. I can give the exact cause if you post a link to your saved configuration or screenshots.
quantumfate
0
Mar 11, 2021
You saved my *ss
Kalcitus
0
Apr 5, 2021
This was it, thank you.
Duncan
3718
Feb 6, 2019
Help is on the way. I'll check with the team and get back to ya.