Sennheiser HD 6XX right side cutting out?
more_vert
Hey, I just wanted to ask if anyone else is having the same issue I am... This is the second pair in which the right ear cup has began cutting in and out on me, and I'm wondering if anyone has seem something like this happen and has fixed it with a better cable. If so, I'd like to know which cable to pick up. I've only had these a few months, I'm surprised to see this kind of thing happen so quickly.
0
13
remove_red_eye
747
bookmark_border
Xzygy
1

search
Bullet4Justice
1
May 5, 2020
bookmark_border
your issue just happened to me and it’s the right side as well. Shame this problem seems to be happening to many people, you can only imagine that I’m a college student and I’ve saved for them for about a year to be able to buy them and this happens! I owned them for only a year too. Shame!
May 5, 2020
MattyMcMattface
0
Apr 20, 2020
bookmark_border
I just had the same issue start with mine. I figured it was a cable issue so I purchased an upgraded cable, but the issue hasn't improved. I've also tried swapping the L/R cable ends to be sure it isn't two janky cables (a long shot but easy enough to eliminate). The right side will drop out, crackle or lower in signal strength. Tapping the outside of the grill will sometimes help, but not always (and obviously not a decent fix). Has anyone had any luck with Drop customer service?
Apr 20, 2020
DorianLS
3
Apr 16, 2020
bookmark_border
I just started having this problem myself. I haven't experimented yet to determine if the problem is the cable or something internal. It's definitely not the amp as I plugged in my old HD580 and it works fine.
Apr 16, 2020
cunmerou1
1
May 11, 2020
bookmark_border
I had never thought about that, I was wondering why my 6xx's had no sound in one ear despite not having been used a ton. Flipped the cables and problem moved to the other ear, so happy it's the cable that's the problem. I had debated throwing them out, but really glad that I saved them, thank you for the advice!
May 11, 2020
cunmerou1
1
May 11, 2020
bookmark_border
6xx should be a 650 with a different name, so everything should be the same, including cable. If I were you I'd buy a cable for the 650's off of amazon, worst case scenario and they don't fit, you return the cable.
May 11, 2020
Strider2879
0
Apr 9, 2020
bookmark_border
Just received my set and am having the same problem, it's intermittent. Will try swapping the cable around to see if it's the cable or something internal in the cup. Definitely won't open it up and send it back for replacement, bought the 789 amp as well so will check if thats the culprit as well.
Apr 9, 2020
Strider2879
0
Apr 29, 2020
bookmark_border
So I ended up having to reorder the headphones and amp as I was told they could not process a price adjustment and replacement at the same time. So to simplify things, I opted to just return everything and I thought I was reordering the same things. Read positive reviews on the fenestrated sheepskin earcups and placed a separate order for the current drop losing a $10 discount in favor of a better product and dropped the cables since I read reviews about problems with the molding of the 2pin connectors having to be forced in due to a missing notches to match the keys on the headphones on top of that there was its 2.5mm connector and the drop has no option for converter so that I can connect it to the balanced output of the thx aaa 789. I recently received the new headphones and amp but noticed that my previous order had include free IEMs nuforce Strides selling right now for $75, so I asked about that and guess what? First response is sorry that deal is expired. Then, I proceeded to ask for an adjustment and was given $25 discount taken off of the warranty to compensate for the loss of a $75 product. I might have just taken the $25 if that was offered upfront in the initial email but now I’ve decided to return this order and cancel everything else Toppings D70bt, fenestrated sheepskin earcups, 2 bluwave Bluetooth portable amps. Will take my money elsewhere!
Apr 29, 2020
Heefty
1360
May 6, 2019
bookmark_border
Were both pairs plugged into the same amp? Do you notice an change on it when you move the plug/cable around? If you change to a different amp/phone/laptop/etc does it still happen?
May 6, 2019
erickong
5238
Audiophile Moderator
Apr 20, 2019
bookmark_border
Very odd that this has happened to two pairs in a row. Have you tried blowing out the area that the removable cables plug into with compressed air? Is the 3.5mm jack pressed all the way into the source? Is the output source broken? You could try reaching out to Massdrop CS again about a warranty claim.
Apr 20, 2019
Xzygy
1
Apr 20, 2019
bookmark_border
So I think it's definitely the cable, as reversing them transfers the problem to the other cup, but I'd expect Sennheiser to have more robust cables than this. I have a pair of 598 which have lasted for years. I've just replaced the ear pads and gone back to using that. Same output source, cable was plugged in, and compressed air didn't seem to fix it. It looks like the cable just failed.
Apr 20, 2019
erickong
5238
Audiophile Moderator
Apr 20, 2019
bookmark_border
https://www.massdrop.com/buy/fanmusic-c6-cables-for-hd6xx-headphones-andmore?utm_source=linkshare&referer=BPKDQH There is this drop. I wonder if you can get a replacement for just the cable
Apr 20, 2019