Received my HighProfile CTRL today July 14th, 2020. I was super happy to start using this board however, after plugging it into my computer - the board did not even light up or work. I was unable to type on the board so I decided to see if I could configure the board. After browsing through the community - I found that these new boards comes with a new chip. I downloaded the fix version that was provided and did the troubleshooting. I forgot to mention im on windows 10.
more_vert
Things that I have done:
  • Tried different usb c cables
  • Tried different usb ports
  • Tried different computers
I'm not sure what's going on but here's logs that I can provide: C:\Users\christian\Downloads\dropctrl>mdloader.exe --first --restart Massdrop Loader 1.03 Massdrop Loader Copyright (C) 2018 Massdrop Inc. This program is Free Software and has ABSOLUTELY NO WARRANTY Scanning for device for 60 seconds ..................60060306 Device port: COM7 (SAMD51J18A) Opening port 'COM7'... Success! 60060306Found MCU: SAMD51J18A Bootloader version: v2.20 Mar 27 2019 10:04:47 [ctrl] Applet file: applet-flash-samd51j18a.bin Applet Version: 1 Booting device... Success! Closing port... Success! C:\Users\christian\Downloads\dropctrl> The keyboard does not work at all even with the success logs. I'm not sure if this is helpful but I get no devices found when typing --list. C:\Users\christian\Downloads\dropctrl>mdloader.exe --list Massdrop Loader 1.03 Massdrop Loader Copyright (C) 2018 Massdrop Inc. This program is Free Software and has ABSOLUTELY NO WARRANTY Bootloader port listing ----------------------------- No devices found! C:\Users\christian\Downloads\dropctrl> I have had the ALT and had no issues configuring my board at all. I'm not sure if I should be concerned because the board should work right out of the box. Any help would be appreciated. And yes, I have already contacted Support.
0
9
remove_red_eye
65
bookmark_border

search
Aspherical90
2
Jul 30, 2020
bookmark_border
I had exactly the same issue as yours, and ran through the same troubleshooting process. Unfortunately nothing works. Have lodged a RMA ticket to support and waiting for response
Jul 30, 2020
hdsharpe1
14
Jul 22, 2020
bookmark_border
If your board didn't light up on plug in you may have gotten a bad one. However, the only thing that I notice you're not saying when doing the process is pressing FN+B for 3 seconds after hitting enter to start flashing.
Jul 22, 2020
chrispyyesus
0
Jul 22, 2020
bookmark_border
That's what I'm thinking.. I should have clarified that on my initial post, but I've tried that as well.
Jul 22, 2020
chrispyyesus
0
Jul 20, 2020
bookmark_border
Downloaded the fix files from GitHub and still nothing... C:\Users\christian\Downloads\massdrop>mdloader_windows.exe --first --download massdrop_ctrl_preset_ctrl_default.bin --restart Massdrop Loader 1.04 Massdrop Loader Copyright (C) 2018 Massdrop Inc. This program is Free Software and has ABSOLUTELY NO WARRANTY Scanning for device for 60 seconds .......................... Device port: COM5 (SAMD51J18A) Opening port 'COM5'... Success! Found MCU: SAMD51J18A Bootloader version: v2.20 Mar 27 2019 10:04:47 [ctrl] Applet file: applet-flash-samd51j18a.bin Applet Version: 1 ERROR: Parser: Could not open file for read! Error: Could not parse file! Closing port... Success! C:\Users\christian\Downloads\massdrop>
Jul 20, 2020
chrispyyesus
0
Jul 25, 2020
bookmark_border
Yeah I realized that but still didn’t work. I even compiled a new file on a different name.
Jul 25, 2020
Elbert
1908
Mech Keys
Jul 27, 2020
bookmark_border
Should probably try a replacement then. You said you have already contacted Support. You can link this thread to show you've already tried to troubleshoot.
Jul 27, 2020