shopping_cart

Does anyone else have or have had this problem?

more_vert
I have recently picked up a custom keyboard cable from MelGeek, this thing looks amazing. However for some reason my keyboard will work with it for only so long and then poof nothing will register. What I find odd is that the keyboard will still light up like nothing is wrong. It just won't register ANY keypresses. I have tried to wiggle the cable the keyboard and on the pc and with no solution. I've tried usb extension and usb hubs, usb 2.0, usb 3.0, usbc to usbc, nothing seems to fix this problem. If figure it has to be the cable or something, but I just think that it's odd that the keyboard is registering and lighting up but no key presses are picked up. Has anyone had or have had this similar problem and does anyone know how to fix it!?
Vote
4

search
close
ottobonn
10
Oct 6, 2020
Do you happen to have console logs enabled on the keyboard? If your keymap is printing logs in QMK and your computer is not consuming them, eventually the buffer on the board will fill up with messages and the keyboard will seem to freeze. It would happen with any cable, so you could try another cable to see if it's reproducible.
ireallydumb
1
Aug 28, 2020
Some keyboards have a locking feature, have you tried looking into that. I know one of mine has this feature and found that it is so much faster to just reset the board then to unlock. Simply because I can never remember which key combination it is to unlock the thing..lol
Have you tried asking in the discussion area of the product?
TonyFerraro54
7
Aug 29, 2020
It seems to be a cable issue I think, I have tried my other boards and they seemed to work. However after further use those boards stopped working as well.