If you are having problem flashing new batch of Alt
more_vert
If you are getting "Error: Could not find a valid device port!" while trying to flash the new batch of Alt High Profile on or around Aug 24, 2020. The fix is to download 1.03 mdloader source code from Github. https://github.com/Massdrop/mdloader/releases Change the Chip ID in line 38 of mdloader_common.c to "0x60060305". Compile and flash. Thank you to: The badasses fauxpark and sigprof in the QMK discord for figuring out the problem when it first appeared with the CTRL High Profile. And thank you to: Marc Wilkinson (Drop user name: marcw) for compiling a binary version of mdloader that prints the Chip ID when trying to connect to the keyboard. When trying to flash with his binary version, I saw it repeatedly printing 60060305, which I guessed is the new Chip ID. Here is a working Linux binary I built: https://drive.google.com/drive/folders/1_k_i_shOIjwvotyelGhwG1kTuZ6QsPLj?usp=sharing Can someone make a Windows build? I don't know how to "make" for Windows. Shame on Drop for making crappy firmware loader. VIA conflagrator show be a standard for a 200 dollar QMK keyboard. Please make your keyboards work with VIA.
thumb_upLouie Tranchitella, MericanShitposter, and 5 others
7
3
remove_red_eye
249

search
close
artfulx
1
Sep 6, 2020
Great work figuring all this out! I also used marcw's bin which printed out 60060005 for my new Alt (Shipped from Drop Aug 24). Unfortunately my programming skills are very basic and I don't know how to compile exe's, hopefully Drop can fix their firmware or as you said, at least make it work with VIA! Edit: MMurphy4096 on Github uploaded a fixed bin for the 60060005 Chip ID. https://github.com/Massdrop/mdloader/issues/32#issuecomment-682385992 Worked perfectly for me, finally!
(Edited)
1nuyasha
0
Sep 4, 2020
Just when i thought why the heck is the guide not working
afynyth
6
Aug 27, 2020
The windows one I compiled and shared through google drive worked for someone else who was having this issue: https://drive.google.com/drive/folders/12ypreuxCE2ewbo5ZlqnPyws1QIOWHV4n?usp=sharing Link to that thread: https://drop.com/buy/drop-ctrl-mechanical-keyboard/talk/2692202 You should probably mention in your post that this recompiled loader only works for this batch of alts, so new users in the future know that there might be a different ID for them (if drop doesn't fix the mdloader for whatever reason). It also makes zero sense why Drop didn't fix this restrictive ID issue with the 1.04 binaries. Thanks for the find dude
(Edited)