Your Friend gave you $10 to spend on your first purchase on Drop! Sign Up to learn more.

How to Configure your CTRL Keyboard!

more_vert
search
Hey everybody! Thank you for purchasing your Massdrop CTRL Mechanical Keyboard. We hope you’re enjoying it so far. If you’ve landed here, you probably want to take full advantage of the keyboard’s features so you’ve come to the right place. We’ll start with the basics, then we’ll move on to complete custom configuration.
THE BASICS
Default Hot Keys Hold FN + listed keys to activate LED Keys
Fn + A: LED Pattern Select Previous Fn + D: LED Pattern Select Next Fn + W: LED Brightness Increase Fn + S: LED Brightness Decrease Fn + Q: LED Scrolling Pattern Speed Decrease Fn + E: LED Scrolling Pattern Speed Increase Fn + Tab: LED Toggle Breathe Effect Fn + Caps Lock: LED Toggle Scrolling Pattern Direction Fn + X: LED Toggle On/Off Fn + Z: LED Toggle Mode (Keys+Edge, Keys Only, Edge Only, Only modifiers) Media Keys
Fn + Page Up: Volume Up Fn + Page Down: Volume Down Fn + Print: Mute Fn + Insert: Play/Pause Fn + Home: Stop Fn + Delete: Previous Fn + End: Next Keyboard Option Keys
Fn + N: Toggle keyboard 6KRO/NKRO (Default state 6KRO)
CUSTOM CONFIGURATION
How do I configure my keyboard? Note: You will currently need a second keyboard to complete the 3rd step of this process. 1. Create your configuration. 2. Compile the firmware with your configuration. Use our web-based configurator tool to handle both steps at once: https://www.massdrop.com/mechanical-keyboards/configurator . See below for more information about our configurator. If you are comfortable with programming and want to use QMK functionality that our configurator does not support, you can manually create and compile your configuration by checking out the official QMK repository: https://github.com/qmk/qmk_firmware . CTRL Keyboard is in the folder "massdrop/ctrl". QMK setup instructions are here: https://docs.qmk.fm/#/newbs 3. Load the firmware onto your keyboard. To load the firmware onto your CTRL keyboard, download the appropriate loader application for your computer's OS here: https://github.com/Massdrop/mdloader/releases. Then follow the instructions here: https://github.com/Massdrop/mdloader . We are working with Jack and the other QMK contributors to get the loader application integrated into the next version of QMK Toolbox to simplify this loading process.
MASSDROP KEYBOARD CONFIGURATOR
https://www.massdrop.com/mechanical-keyboards/configurator When you first go to the configurator, you will be prompted to choose your keyboard (only CTRL Keyboard available for now). After choosing, you will see a top-down view of the keyboard and a layer selector on the right side. By clicking on a key, you can customize its behavior by selecting another key or function in the panel that appears below the keyboard. The currently available behaviors are: - Keys - Individual keys such as letters, numbers, media keys, and function keys. - Layer - Activate and deactivate layers. The CTRL Keyboard ships with a keymap where the Fn key activates layer 1. - Modifier - Send multiple modifiers with a single key press or allow a key to be a modifier when held and another key when tapped. - Special - Behaviors specific to the keyboard. For the CTRL Keyboard, these control the LEDs. After you have configured the behaviors to your liking, click the "Compile & Download" button in the top right to download the compiled firmware for your configuration. This typically takes around 30 seconds. You will need to load this compiled firmware onto your keyboard. See step (3) above for instructions. If you are logged in to Massdrop, you will see a "Save as a New Copy" button next to the "Compile & Download" button. Clicking this button will save your configuration, allowing you to revisit it and modify it. The next time you go to the configurator, you will see your saved configurations above the list of keyboards. About Layers Layers allow you to configure your keyboard with more behaviors than its number of physical keys. For example with the CTRL Keyboard, by default, when you hold Fn + A to change the LED pattern, the keyboard is actually activating Layer 1 and sending the code for switching to the previous LED pattern. The physical key that is mapped to the letter A on Layer 0 is mapped to changing LED patterns on Layer 1.
search
For each key, its behavior is determined by the highest active layer. For the highest active layer, if the key's behavior is "transparent" (denoted by a grayed-out "(trns)" on the keyboard display), then it falls back to the next-highest layer where its behavior is not transparent. The QMK documentation has some tips for working with layers: https://docs.qmk.fm/#/feature_advanced_keycodes?id=working-with-layers

Configurator Development Roadmap Our configurator tool is still a work-in-progress. Here is what you can expect to be added to the tool in the future: 1. Merge our QMK changes back into the main QMK repository 2. Macros support 3. Support for changing some QMK settings 4. Support for more keyboards
Having any issues or generally need some help?
Let us know in the discussion and we’ll give you a hand.
(Edited by moderator Elbert)
101
1.1K
remove_red_eye
186.7K

search
close
kami_kaze
0
May 3, 2021
This keyboard is the most expensive piece of garbage I ever seen. I completelly regret for buying this thing.
https://www.youtube.com/watch?v=1VsTKWfClhA After spending 6 hours trying to get my keyboard recognized by mdloader.exe, I made a tutorial to help anyone else who is struggling. This tutorial will guide you step by step to enable persistent memory so your RGB settings save when you unplug the keyboard. Massdrop PLEASE just ship your boards with EEPROM memory enabled. It's such an easy fix.
ankit1738
1
Apr 22, 2021
@Drop+MechKeys In the website configurator there is no option for Screen Brightness UP/DOWN. Please add it to the media buttons. These two keys are available on the config.qmk.fm as KC_BRIU and KC_BRID.
(Edited)
FOR ANY OF YOU WHO CANT GET THE DEVICE TO SHOW UP / Could not find a valid device port! (Windows 7 ) I needed to enable driver searching from windows update. This automatically downloaded a missing COM driver. Control Panel > Computer > Advanced System Settings > Hardware > Device installation settings > YES After that, I used this -> https://github.com/nicoelayda/mdloader I just followed the instructions underneath and it actually worked. FINALLY. I spent literally 6 hours today trying to figure this out. Crazy how this isn't a default feature. (Edit : Just made this into a video tutorial -> https://www.youtube.com/watch?v=1VsTKWfClhA )
(Edited)
mdloader not working 4.21.2021 When I try to use mdloader.exe, it just times out after 60 seconds with the error : "Error: Could not find a valid device port!" I exhausted every single result I could find on Google and tried everything. I even tried it on a secondary computer just to make sure. Its inexcusable that a keyboard this premium and expensive lacks such a basic feature that can be found on every other RGB keyboard on the market.
tom-ganks
22
Apr 20, 2021
WHY IS MY KEYBOARD BRICKED!!! HELP Massdrop Loader 1.05

Massdrop Loader Copyright (C) 2018-2020 Massdrop Inc.
This program is Free Software and has ABSOLUTELY NO WARRANTY

Scanning for device for 60 seconds
.
Device port: /dev/cu.usbmodem1432201 (SAMD51J18A)

Opening port '/dev/cu.usbmodem1432201'... Success!
Found MCU: SAMD51J18A
Bootloader version: v2.18Sep 4 2018 16:48:28
Applet file: applet-mdflash.bin
Applet Version: 1
Writing firmware... Complete!
Booting device... Success!
Closing port... Success!



See if this helps https://www.youtube.com/watch?v=1VsTKWfClhA This involves flashing the default firmware back on to the keyboard so it should fix it.
tom-ganks
22
Apr 24, 2021
Yea I just ran $./mdloader_mac --first --download massdrop_alt_default-smarteeprom.bin --restart And stopped there. Way too much of a headache to change the rgb via mass drops version of qmk. I mean after that the keyboard worked again, but still the command make doesn’t work at all, so I just gave up. I dunno if it is easier on windows, but on Mac, this was a nightmare.
Mr_Steve123
0
Apr 20, 2021
Is it safe now to use the mdloader?
Scoobmx
44
Apr 19, 2021
OK, so I tried to reconfigure my Ctrl today with a new LED scheme, but got a problem: Massdrop Loader 1.05 Massdrop Loader Copyright (C) 2018-2020 Massdrop Inc. This program is Free Software and has ABSOLUTELY NO WARRANTY Scanning for device for 60 seconds .............. Device port: COM5 (SAMD51J18A) Opening port 'COM5'... Success! Found MCU: SAMD51J18A Bootloader version: ♠♥♠`v2.20 Mar 27 2019 10:04:47 [ctrl] Applet file: applet-mdflash.bin Applet Version: 1 Writing firmware... Error: Sent bytes != written bytes (8192 != 0) Closing port... Success! Now it refuses to turn on, and I can't flash anything into it again. Is it bricked?
tom-ganks
22
Apr 24, 2021
Yea that didn’t work for me at all. Had to run this command in terminal $ ./mdloader_mac --first --download massdrop_alt_default-smarteeprom.bin --restart this whole process is so not worth it for the stress that it cause just to switch the keys around and have some cool lights. This entire experience scarred me. Way easier to just follow QMK and use that. It’s just altering the lighting is way more intense regarding the code needed than just altering and adding layers to the keys. Imo I’m not gonna bother trying to change my rgb. I changed the keys I wanted via qmk and that’s it. Having a seemingly bricked $250 keyboard was way too much to handle. Fuck this software, fuck massdrop, don’t say this is that easy. I was only able to dig out of my grave because I know how to program and troubleshoot. I can totally see so many people in the same boat just following the docs and bricking their keyboard and being completely helpless because they don’t know programming. I can’t express how much I fucking hated this entire experience. Such a waste of time to literally just get my keyboard in working order.
Jhonnel
1
Apr 13, 2021
Oh god! Didnt think we would have soooooo many issues with the configuration! Honestly I though I was an isolated case but no, well in my case I do run every single step, have followed every single tutorial but the configuration just wont work, always the same issue "Could not find a valid device port!" I have tried changing folder direction, tried to use cmd and powercell but no, tried to conect it directly to the pc and also using a hub and also no, it just wont work, if anyone has an idea that could work its greatly appreciated. Hope they actually create a dedicated software for this and make it easier to use and not being stuck with the default setting, that what makes ppl drive away from your products :(
100% agree. You shouldn't have to hack into the pentagon to change the default settings on a near-$300 keyboard.
https://www.youtube.com/watch?v=1VsTKWfClhA After 6 hours of searching I finally figured it out and made a tutorial to help everyone out.
shawn.wang
13
Apr 7, 2021
The online configurator is not working at the moment, keep stuck and can not download the file
Showing 18 of 291
keyboard_arrow_up
Newest
291 OF 291 POSTS
May 8, 2021
keyboard_arrow_down
Oldest