Massdrop ctrl problem ,stop responding/stop working after a period of time

more_vert
Ishere anyone encounter this issue with the ctrl? Recently i have move to a new country and i have change my PC setup(second PC) along with my ctrl keyboard. However the ctrl will automatically disconnected from the windows after a period of use specially when i was gaming with it. Once it got disconnected the LED still power on but the effect will freeze and can't press any keys. So when it happen i tried to re-plug the keyboard and it won't recognise by windows and turn back on right away. This problem only happen with my second PC but it work perfectly fine with my old setup without seeing this problem at all. The only way i can turn back on the keyboard is to wait around 10 to 20 mins and reconnected the board then it turns back on. Since i don`t know what is the problem causing the issues so i've tried different way solve the problem and this is what i attempted to do so far: -Try all the usb port on my PC including the extension -Use a different type-c to usb cable -Installing firmware  -Disable the power saving option -Reinstall windows And those are the things i've tried t o do so far but the ctrl still have that issue. Is there anyone encounter that issue and and a way to solve or identify what causing the it to disconnect and stop working?
100% upvoted
2
10
remove_red_eye
1K
Elvis_Law
2

search
close
Charblee
4
Aug 23, 2020
I’m currently experiencing the same issue. I contacted Drop support. It’ll be 5-7 days for them to respond. I’m getting close to the return window with Amazon, so I bought another one to test and see if it experienced the same issue or not. purchased mine from Amazon since they’re in stock there. It’s really weird... I can’t find a single video on the internet discussing any of the problems the CTRL has.. interesting..
(Edited)
firewyre
48
Nov 3, 2020
Did they RMA it for you? My CTRL is doing the same and it's driving me nuts.
Jpl25
2
Jun 11, 2020
Any solution to this? I'm having the same problem right now and it's very annoying! ><
bumiuchew
0
May 14, 2020
I have the same problem here. I was using the usb Ugreen adapter (from usb 3.0 to type C) to plug it to my Mac. Now I'm using the Baseus hub instead, and the problem started to happen after 2 days of using the hub. I've switched back to use the ugreen one and still can't solve the problem. Anyone has any idea?
burksy
1
May 6, 2020
@Elvis_Law Did you ever find a solution to this problem? I never found a solution and am currently having the exact same issue unfortunately. Drop has already said they wont RMA my board as I am outside of the warranty period. Ever get to the bottom of the issue?
Elvis_Law
2
May 11, 2020
Fortunately I got a RMA on my board by drop that's how it solved.
Elvis_Law
2
Jul 2, 2019
so is properly the board itself and not because of other software?
When you respond to someone. Make sure you respond to their comment and don't reply to your own thread.
search

Ceds
0
Jun 30, 2019
I've also had that issue on my ALT keyboard. I had to RMA it. However my issues started the second day I had it.