Showing 1 of 1661 conversations about:
RadioHamster
7
Jan 4, 2019
bookmark_border
Certain keys on my keyboard (o and k so far) keep repeating randomly. This happens multiple times every day and the only way to reset the repeat is unplug and plug back in the keyboard. This seems to be a known issue but I can't find a solution. Do I need a replacement? edit: this happens while typing, not when I'm inactive and also switching switches doesn't fix it more edit: I actually found out how to reproduce this problem. I was accidentally pressing the function key when I was typing, and pressing any key + fn + n was making it repeat. Is this normal behavior or is this a problem with NKRO?
(Edited)
Jan 4, 2019
rafamundez
36
Jan 11, 2019
bookmark_border
This happens to mine only when I connect/disconnect the USB from my PC. After replugging it in... it needs 1-2 computer restarts before this problem goes away completely. Only way this issue returns if if I connect/disconnect the USB again.
Jan 11, 2019
fullCircle801
2
Jan 12, 2019
bookmark_border
I have the exact same issue. Any word on a cause or solution? Anything I can change in QMK to help?
Jan 12, 2019
RadioHamster
7
Jan 21, 2019
bookmark_border
Nope, it seems that replacement is the only option. I'm still waiting for mine.
(Edited)
Jan 21, 2019
fullCircle801
2
Jan 22, 2019
bookmark_border
Looking through the code I found a commented out section of "config.h" that when uncommented forces the keyboard into NKRO mode (which I don't know why you wouldn't want). With that uncommented I have no need to toggle the NKRO and removed it from my "keymap.c" so I no longer run into the issue of accidentally triggering it and disabling my keyboard. Not the best solution, but a solution nonetheless.
Jan 22, 2019
RadioHamster
7
Jan 22, 2019
bookmark_border
Oh, I see. Thanks for the info. I'll probably use your method if my replacement behaves the same way :)
Jan 22, 2019
RadioHamster
7
Jan 22, 2019
bookmark_border
Ok, I just got my replacement and it doesn't seem to have this problem anymore. But then I was weirdly charged $15.33 for customs. I'll have to talk to MD about it.
Jan 22, 2019
View Full Discussion