Showing 1 of 43 conversations about:
esoomenona
71
Apr 21, 2014
bookmark_border
Just to be clear, before I choose to purchase, these ONLY work with Bluetooth 4.0?
Apr 21, 2014
FIND_team
43
FIND_TEAM
Apr 21, 2014
bookmark_border
Yes. Will work with phones running Android 4.3 and above and all iPhones starting with the 4s. iOS 7 will be needed.
Apr 21, 2014
View Full Discussion