Showing 1 of 182 conversations about:
Jutu
2
Sep 20, 2016
bookmark_border
Please note that this does not come with a screen protector, despite the pictures.
Sep 20, 2016
banok
5
Sep 22, 2016
bookmark_border
Mine came with 2 screen protectors.
Sep 22, 2016
Jutu
2
Sep 22, 2016
bookmark_border
Mine didn't come with any, and was defective anyhow. Waiting on a replacement to arrive.
Sep 22, 2016
banok
5
Sep 22, 2016
bookmark_border
That sucks, what's wrong with your unit? Let me guess, bleeding light on the right side of the screen perhaps?
Sep 22, 2016
Jutu
2
Sep 22, 2016
bookmark_border
Yes, that was one issue. But the main issue was that the sound was horrible, and every game was missing some sound from it, replaced by a beeping sound, or what sounded like the censor sound when someone swears on TV. It happened on both actual carts, and the k-cart.
Sep 22, 2016
banok
5
Sep 22, 2016
bookmark_border
It really does seem like the light bleeding is a common issue with these unit. I think I can live with that, but the the sound issues you're having sounds pretty awful, do they even do QA on these before they send them out?
Sep 22, 2016
epsilon748
203
Sep 22, 2016
bookmark_border
I don't think it's "light bleeding". I got mine last night and if you look at it turned off, there's a bar in the right side of the screen that's open to the internals. That's where the light comes out. It appears to have been an intentional design choice. I might sharpie over it with silver marker to match the rest of the screen and see if that helps.
Mine came with two screen protectors, replacement button contacts (in case the buttons ever stop working?), AV card, charging cable, usb charger brick, screwdriver for the battery, and a legit looking Nokia battery. No manual, but this page got me up and running https://gbatemp.net/threads/k101-revo-official-gbatemp-review.339019/
Other than that I have no issues with mine. Loaded in a 128GB microSD and full no-intro ROM sets for GB/GBA/GBC/NES/Master System/GameGear/PC Engine. Updated to newest firmware and spot checked that all the ROMs seem to run OK. Navigation is a bit clunky since I didn't know the shortcuts (which themselves are annoying since they use the * key on the top that's used for brightness). The battery needing a screwdriver to swap is also an annoyance, since I bought spare Nokia batteries to juice it up without a portable charger.
Seems to function fine otherwise. Set the RTC and need to get the cheat files and game photos working tonight. Performance in GBA games is on par with all the other emulators I've used (smooth, no issues). Audio sounds just like my old Gameboy Advance SP in terms of quality - shitty but authentic.
One thing to note, if you get it, pop in a microSD card, and power it on only to get stuck at a blank white screen - it's not defective. You either didn't set up the ksystem folder right, or didn't format the card to fat32.
Sep 22, 2016
Jutu
2
Sep 23, 2016
bookmark_border
I'm sure it's not an intentional design choice, as if you look up some other videos online of the crystal black model, they do not have that light there.
Sep 23, 2016
noreply
20
Oct 22, 2016
bookmark_border
i was able to put sd card into macbook, drag games and then play. fat32 was not used
Oct 22, 2016
View Full Discussion